Alpine PDX 1.1000 keeps blowing fuses. Please help! - - Infiniti G35 & G37 Forum Discussion | panoramic-3d.ru
Show Your Support Become A Premier Member

    > >
  • Reload this Page >
    • Alpine PDX 1.1000 keeps blowing fuses. Please help!


Alpine PDX 1.1000 keeps blowing fuses. Please help!

Thread Tools Rate Thread
Old 11-22-2008, 06:26 PM
Registered User
Thread Starter
iTrader: (9)
Join Date: Jan 2006
location: Orange County, CA
Posts: 2,411
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Alpine PDX 1.1000 keeps blowing fuses. Please help!

I have an alpine PDX 1.1000 amp and a Image Dynamics IDMAX10 D2 v.3 sub and the amp keeps blowing the fuses. I cant figure out whats causing it. The gain on the amp is one notch past half way, but even when I turned it down a little they blew. What could be causing it?
Old 11-22-2008, 06:27 PM
Registered User
Join Date: Jul 2008
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
the fuses are blowing at the amp, or the fuse on the powerline?
Old 11-22-2008, 07:09 PM
k67p67's Avatar
Registered User
iTrader: (86)
Join Date: Dec 2005
location: Rancho Cucamonga, CA
Posts: 2,494
Thanked 19 Times in 17 Posts
Make sure the voicecoils on the sub are wired in series to present a 4-ohm load. Even though the Alpine amp is class-D, it is not rated at 1-ohm so I wouldn't run the voicecoils in parallel.
Old 11-22-2008, 09:59 PM
Registered User
Thread Starter
iTrader: (9)
Join Date: Jan 2006
location: Orange County, CA
Posts: 2,411
Thanks: 0
Thanked 0 Times in 0 Posts
I'm almost a hundred percent sure I wired it correctly. Everything worked fine for 3 weeks. Then I turned the gain up 1 notch and it was fine for 3 days and the the 4 amp fuses blew. I had the amp grounded between the Bose amp bracket and the chassis and then I moved the grounded point to a sanded down spot screwed into the chassis, then I replaced the fuses and they blew again right away.
Old 11-22-2008, 10:12 PM
k67p67's Avatar
Registered User
iTrader: (86)
Join Date: Dec 2005
location: Rancho Cucamonga, CA
Posts: 2,494
Thanked 19 Times in 17 Posts
Something sounds seriously wrong. Turning the gain up slightly shouldn't cause fuses to blow. If anything, the amp would clip and possibly go into a protection mode but wouldn't blow 4 fuses. Sounds like the amp needs to get checked out. You're not having the best of luck with this system. I feel for ya.
Old 11-22-2008, 11:03 PM
Registered User
iTrader: (1)
Join Date: Jul 2008
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
A friend of mine ran two subs off of his PDX1.1000 and ran into the same problem. He contacted Alpine about it and they told him it was a problem with their earlier PDX1.1000 amps caused by too low of an impedance, but it was permanently damaged. IIRC he was running at 1-ohm or 2-ohm and only drawing ~500W. After the fuses started blowing, the amp would only run an 4 ohm load without blowing the fuses.

I'm with k67p67, if you have an ohm-meter, take a reading off the terminals on the box.

If you get desperate, you can also try running higher rated fuses.

Is the amp under warranty?
Old 11-23-2008, 02:07 AM
k67p67's Avatar
Registered User
iTrader: (86)
Join Date: Dec 2005
location: Rancho Cucamonga, CA
Posts: 2,494
Thanked 19 Times in 17 Posts
It's a class-D amp and it's rated at 1KWRMS 2-ohms so it shouldn't have any problem running a 2-ohm load. Nevertheless, your sub is a D2 so it can only be configured at a 4-ohm or 1-ohm load. As long as the DVCs are wired in series, the amp shouldn't be overloading.
Old 11-23-2008, 02:37 PM
Registered User
iTrader: (1)
Join Date: Feb 2005
location: Houston, TX
Posts: 2,047
Thanks: 0
Thanked 0 Times in 0 Posts
I would think it's a faulty amp. Most quality amps come with overload protection so that if the load resistance is too low, then it'll cut or at least reduce the output.

And even if the amp didn't have that overload protection, you can still present it with a low resistance load and still play it just fine with the gain turned low. It's pretty hard to wire just one DVC sub incorrectly. In your case, it's just + from one coil to - of the other. Then connect the open + and - to the amp.
Old 11-23-2008, 07:11 PM
Registered User
Thread Starter
iTrader: (9)
Join Date: Jan 2006
location: Orange County, CA
Posts: 2,411
Thanks: 0
Thanked 0 Times in 0 Posts
it seems like an amp problem. i bought it on craigslist and I dont have a warranty. I also dont have the money to buy a new one. Is it repairable?
Old 11-23-2008, 07:13 PM
k67p67's Avatar
Registered User
iTrader: (86)
Join Date: Dec 2005
location: Rancho Cucamonga, CA
Posts: 2,494
Thanked 19 Times in 17 Posts
No way to determine the extent of the damage without sending it back to Alpine.
Old 11-23-2008, 08:04 PM
Registered User
Thread Starter
iTrader: (9)
Join Date: Jan 2006
location: Orange County, CA
Posts: 2,411
Thanks: 0
Thanked 0 Times in 0 Posts
could it be anything else besides the sub wiring or a faulty amp? I just dont get why the first 3 weeks I used it, it was fine, but now there are problems
Old 11-23-2008, 10:03 PM
Registered User
iTrader: (5)
Join Date: Jul 2007
Posts: 1,229
Thanks: 0
Thanked 0 Times in 0 Posts
I worked at an alpine dealership and it's fairly normal for those to pop fuses or rep just told us to step it up to I believe there's 4-25 amp fuses, so step it up to 30 or if it has 30 amp fuses go to 40 amp. This was straight from the distributor. the protection circuitry in the amp is VERY good so if you blow fuses AFTER that there's a problem with the amp/wiring.
Old 11-23-2008, 10:24 PM
Registered User
Join Date: Jul 2008
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
it is the worst idea possible to just use a higher rated fuse, the fuses are there for a reason.

Gain adjustments shouldn't cause fuses to blow in any way, and likewise gain SHOULD NOT be used similar to a volume control, set everything to even when tuning your system, and start at your source unit and work your way back.

My guess is it is an installation problem, I have been installing mobile electronics 6 days a week for 3 years, and 99.99999% of the time it is an installation error, and most defective products are deemed defective because they have been installed incorrectly, and subsequentially damaged. Go get a reputable shop to troubleshoot it and if necessary re-install everything correctly for you. There is only a remote possibility that the amp is defective. A good common rule of thumb in mobile electronics is it either works or it doesn't. Nothing is that complicated inside a car. If it is blowing fuses the amp is not now 'defective'. My guess is that was just the last straw and there is a greater installation problem.


How about you post some pictures of everthing.
Old 11-24-2008, 10:07 AM
Registered User
iTrader: (5)
Join Date: Jul 2007
Posts: 1,229
Thanks: 0
Thanked 0 Times in 0 Posts
I'm just relaying the information that Alpine Canada. gave to my boss, we were skeptical at first as well. But for the amount of PDX products that are defective out of the the box, VERY rare. however that said... Clockwo12k is correct in assuming there's a good chance there's something wrong with the install. Check to make sure your remote wire, and RCAs are not pinched or severed anywhere. if they are that could cause a problem.
after you go over the install that's when I'd suggest going to an Alpine dealer and ask them if they can bench test the amp.
Old 11-24-2008, 08:22 PM
Registered User
Thread Starter
iTrader: (9)
Join Date: Jan 2006
location: Orange County, CA
Posts: 2,411
Thanks: 0
Thanked 0 Times in 0 Posts
I put new fuses in and tried it again. I put the gain one notch below halfway and the volume around 18 on the bose headunit the sub works. But when I turned the volume to like 28-29 on the headunit the stop just stops playing. Amp stays on, no fuses blew, just no sound from the sub. Turn the car of then on lowered the volume and the sub was playing again. Any ideas? Will post pictures later.

Related Topics
Thread Thread Starter Forum Replies Last Post
David's IP G35 Coupe davizzle Picture Share 14 04-26-2016 07:10 PM
David's 2007 G35 Coupe Build Thread davizzle Media Share G35 Coupe V35 18 12-13-2015 01:47 PM
A/C issues led to finding MELTED fuse box! 2003.5 Learned Hand G35 Sedan V35 2003-06 1 10-01-2015 10:02 AM
Another A/C issue. Any help? Jcruzg35 G35 Coupe V35 2003 - 07 1 09-26-2015 05:47 PM
Air conditioner is only blowing towards the feet vents master111 G35 Coupe V35 2003 - 07 2 09-25-2015 09:32 PM


Tags
03, 11000, alpine, audio, blow, blowing, fuse, fuses, g35, ohm, pdx, pdx11000, sedan, stereo, subs
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:45 PM.


Copyright ©2002 - 2017, panoramic-3d.ru All Rights Reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in:

Related pages


pioneer avic z140bh for salehks catalytic converter2003 infiniti g35 wheelsbank 2 catalytic converterautomatic shifter knob replacementgeneral tire g-max as-03 reviewpioneer avic d3 bluetoothauto zone rental toolszymol concours review4.3 l turbo kit1993 rx7 twin turboracing hart crinfiniti g35 custom8th gen civic exhaustnissan rays wheels350z substerm lab for salekeyless entry remote wont work2008 g35 coupe specstemporary tag ga1010 tires richmondg35 straight pipeamsoil suckstint brake lightsbuddy club railsonlinetiresseat belt harness barmotodyne08 g8 gt specsscion fr-s forumsupercharger soundsiphone 5 aux cordmotordyne mrev204 infiniti g35 horsepoweryokahoma yk580la habra plating2003 skyline 350gt300zx v8 engine swap8th gen civic si sedanimage dynamics idq 12 v2buy xxr wheelsare non refundable deposits legaltiresavings coupon codegti fastengine torque dampercelica widebodyhks camp 2monroe sensatrac2003 infiniti g35 sedan rims350z starterfhp8000btg35 top speedsamco radiator hose kit8mm wheel spacerseagle forged pistonsstall torque converter2007 saleen s281 specssuper advan v2memphis mojo m3llumar tint reviews350z front lipneoprene bushingscheap air bag suspension kitceramic brakes vsce28 blackspark plug iridium vs platinumhow to get rid of haze on headlightspower acoustik nb 2duralast ball jointspac stereobuy rb26dett enginenitrous direct portadvan avs model 6g2 green caliper painthoen bulbsnismo kit