need help with pdx 1.1000 install!! - - Infiniti G35 & G37 Forum Discussion | panoramic-3d.ru
Show Your Support Become A Premier Member

    > >
  • Reload this Page >
    • need help with pdx 1.1000 install!!


need help with pdx 1.1000 install!!

Thread Tools Rate Thread
Old 06-12-2008, 12:28 PM
Registered User
Thread Starter
iTrader: (3)
Join Date: Sep 2007
location: Calgary, Alberta
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
need help with pdx 1.1000 install!!

Hi all!
I just put in my pdx 1.1000 to power my two kicker subs. Now, I am no car audio install genius by FAR!!..so I need some help.
I wired the subs into a 4ohm load as per diagram and that left me with two negative leads and two positive leads that i twisted together to make one positive and one negative for my speaker input to the amp.

I am getting power to the amp and the subs are working up to a certain volume, once I go past 7-8 on volume there is a thud, then no bass. I have to turn off the car and restart it then I have bass again untill vol 7ish.

I don't have a cap or anything and this is draining mad power from the rest of the car....

Any ideas of what I am doin wrong???
Attached Thumbnails
need help with pdx 1.1000 install!!-2dvc_4-ohm_mono.jpg
Old 06-12-2008, 01:43 PM
Registered User
iTrader: (7)
Join Date: Apr 2004
location: Orlando, FL
Posts: 8,001
Thanked 6 Times in 5 Posts
What Kicker subs do you have and if they are dual voice coils, what is the ohm rating (impedance) of each voice coil?

The PDX 1.1000 is a monoblock amp that has two plugs to connect the speakers. You can use one plug for each speaker.
Old 06-12-2008, 02:05 PM
Meatshackle's Avatar
Deep Sea Moderator
iTrader: (1)
Join Date: Nov 2002
location: Virginia Beach
Posts: 4,736
Thanked 0 Times in 0 Posts
Aren't the pos and neg wired in parallel inside?
Old 06-12-2008, 10:22 PM
Registered User
Thread Starter
iTrader: (3)
Join Date: Sep 2007
location: Calgary, Alberta
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
I have 2 10" comp VR's the Kicker site says they are 2/4ohm DVC....whatever that means.
I get mad signal discharge every time i turn the car on too!...but that was there before from the other **** "professional" install I had done.
Old 06-12-2008, 10:24 PM
Registered User
Thread Starter
iTrader: (3)
Join Date: Sep 2007
location: Calgary, Alberta
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Meatshackle
Aren't the pos and neg wired in parallel inside?
Not sure what that is supposed to look like
Old 06-12-2008, 10:27 PM
Meatshackle's Avatar
Deep Sea Moderator
iTrader: (1)
Join Date: Nov 2002
location: Virginia Beach
Posts: 4,736
Thanked 0 Times in 0 Posts
Your amp manual would tell you if it's wired that way. Most higher end monoblocks are wired so you don't have to wire your speakers together outside they just plug into the amp individually.
Old 06-13-2008, 11:32 AM
Registered User
iTrader: (7)
Join Date: Apr 2004
location: Orlando, FL
Posts: 8,001
Thanked 6 Times in 5 Posts
Your problem is the way you have wired the DVCs. Your amp is getting a 1 ohm load, so it will shut off.

Wire the DVCs on the subs in series and then the subs in parallel form so you'll provide the amp with a 4 ohm load.

Or you can wire the DVCs of the subs in series and connect each sub to one of the Alpine speaker connector plugs.
Old 06-13-2008, 01:21 PM
Registered User
Thread Starter
iTrader: (3)
Join Date: Sep 2007
location: Calgary, Alberta
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Gilley, do you have a diagram or know where I can get one to set up the DVC in seriese and the subs parallel (your first set up)?
Old 06-14-2008, 12:28 AM
Registered User
iTrader: (7)
Join Date: Apr 2004
location: Orlando, FL
Posts: 8,001
Thanked 6 Times in 5 Posts
Connect a wire of the negative from the first voice coil to the positive of the other voice coil. Then connect the empty + and - terminals of the sub to the amp. Repeat for the other side.
Old 06-15-2008, 03:05 AM
Registered User
Thread Starter
iTrader: (3)
Join Date: Sep 2007
location: Calgary, Alberta
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
Gilley, I hooked it up as you said, and it worked good!..seemed to be out of phase for a bit, but that was cuz a wire shook loose...so it worked great for 5 mins....then I don't know what happend but now there is no signal going to the subs. I though it was a loose connection on the speaker input leads... but that didn't help. I thought I may have messed the amp, so i put another one in...still nothing. All fuses a fine...is there anothe fuse I could have blown...(in the deck?) or should I just give up now.
Old 06-15-2008, 09:48 PM
Registered User
iTrader: (7)
Join Date: Apr 2004
location: Orlando, FL
Posts: 8,001
Thanked 6 Times in 5 Posts
If the amp is receiving a signal and is working properly, but no sound is coming out, then it is probably a problem with your sub. It is possible that you wired one voice coil out of phase.
Old 06-16-2008, 01:04 AM
Registered User
iTrader: (3)
Join Date: Mar 2007
Posts: 155
Thanks: 0
Thanked 1 Time in 1 Post
It sounds like your wiring is still messed up. I installed a PDX 1.600 with 2 JLW3's and the amp kept going into protect mode and shutting down after raising the volume. I had to restart the car every time to get the amp back. You should be seeing a red light on the side panel, that means its in protect mode. My problem was that one of the subs connections was not seated all the way and kept grounding itself on the chassis. Check the cabling again, good luck.
Old 06-16-2008, 01:23 AM
Registered User
Thread Starter
iTrader: (3)
Join Date: Sep 2007
location: Calgary, Alberta
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks Rocket! I will check the sub wiring again. The amp still lights up blue, never had a red light yet.

Related Topics
Thread Thread Starter Forum Replies Last Post
Good car Audio places in the KW Cambridge, Guelph area G-MAN (CANADA) Canada 0 09-07-2015 04:51 PM
anyone have issues with powerslot rotors? 3000vr4tt Brakes & Suspension 3 09-07-2015 01:48 AM
FS: UTEC Engine Management System SilverG123 Engine - Electrical 1 09-04-2015 02:12 PM


Tags
1000, 11000, alpine, blow, diagram, fuse, install, light, ohm, pdx, pdx11000, protect, protection, red, wire
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:07 PM.


Copyright ©2002 - 2017, panoramic-3d.ru All Rights Reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in:

Related pages


car speaker grills 6x9how much to replace drive shaftclean kn filter2009 infiniti g sedanhow to blackout chromevolk sf winningsjl 450 4v2ray catena infiniti edison servicetread depot coupong37 twin turbo kitpo175 codenissan 350gt specsntb tire balanceusa spec iphone 5oil treatment stpcold air intake hydrolockpillar wrapkendall motorcredit score 745350z stage 1jbf okcgilmore foam gungtc01g35 traction controlrecalls and tsb04 350z specsbrembo brakes pricesslight tapping noise enginemanual transmission to automatic conversionhow much horsepower does headers addintake manifold boltinfiniti fx35 recalls dashboardvolk te37 center capstokico hp bluealpine sws 10d4maaco paint job pricingquaiffe lsdplasti dip on rims2jz motorsjl audio w7 13.5 box specsonlinetires promo codemyecuswaybar endlinkssilverstar high performance lightingtein basis review2006 infiniti g35 coupe recallscamshaft position timing over advanced bank 1castrol syntec vs mobil 1g35x 2006nissan 350z tire pressurev2 superchargerservice engine soon light meanstinting tail lightsrolling rear fendersmr clean autodry carwash system refillsls2 engine swap04 nissan maxima timing chainturbo kit for 350zpennzoil yellow bottle350z dc sports exhaustlexus ls460 forum2004 wrx 0-60wheel offset calculator visualhow much is a ls1 enginenissan xterra service engine soon lightis 10w30 thicker than 5w30pioneer avic z2 bluetooth adapteraswc steering wheel controlpower pup bully doghow to install steering wheel control adapterbose subwoofer repair06 saleen mustang specsjl audio 13w7 boxobx long tube headersdyno jet dyno